Sluggish Report Generation
Incident Report for Figure Eight
Resolved
Report generation is back to normal.
Posted about 1 year ago. Jul 21, 2017 - 12:41 PDT
Investigating
We have received reports that Platform reports are taking longer than usual to generate.

We are investigating this issue.

Thank you for your patience!
Posted about 1 year ago. Jul 21, 2017 - 11:17 PDT
This incident affected: Customer Portal and API.