Reduced Performance
Incident Report for Figure Eight
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 13, 2018 - 13:43 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Apr 13, 2018 - 13:16 PDT
Investigating
We have received reports of Reduced Performance affecting our Customer portal. We are working to resolve the problem.

Thank you for your patience!
Posted 10 months ago. Apr 13, 2018 - 12:46 PDT
This incident affected: Customer Portal and API.