Intermittent Connectivity Issues
Incident Report for Figure Eight
Resolved
Sporadic connectivity issues affecting our Customer portal have been identified and resolved.

Thank you for your patience!
Posted about 1 year ago. Aug 14, 2017 - 08:21 PDT
Investigating
We have received reports of sporadic connectivity issues affecting our Customer portal. We are working to resolve the problem.

Thank you for your patience!
Posted about 1 year ago. Aug 14, 2017 - 08:14 PDT
This incident affected: Customer Portal and API.