Report generation performance degradation
Incident Report for Figure Eight
Resolved
This incident has been resolved.
Posted Jan 21, 2020 - 14:05 PST
Investigating
We are currently investigating this issue.
Posted Jan 21, 2020 - 09:10 PST
This incident affected: Customer Portal and API.