Platform slow down
Incident Report for Figure Eight
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 14, 2017 - 14:09 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Mar 14, 2017 - 11:50 PDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Mar 14, 2017 - 11:35 PDT
This incident affected: Customer Portal and API.