Report download processing delay
Incident Report for Figure Eight
Resolved
This incident has been resolved.
Posted Jan 29, 2019 - 20:01 PST
Update
We are still processing a backlog of report downloads and we're continuing to monitor the situation
Posted Jan 29, 2019 - 18:14 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2019 - 16:13 PST
Identified
We have received reports of delayed report downloads affecting our Customer portal. We are working to resolve the problem.

Thank you for your patience!
Posted Jan 29, 2019 - 15:40 PST
This incident affected: Customer Portal and API.