Reduced Performance
Incident Report for Figure Eight
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 12, 2018 - 16:25 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jan 12, 2018 - 16:17 PST
Investigating
We have received reports of Reduced Performance affecting our Customer portal. We are working to resolve the problem.

Thank you for your patience!
Posted 5 months ago. Jan 12, 2018 - 15:56 PST
This incident affected: Customer Portal and API.